新闻资讯

News Information

首页 > 新闻信息 > 华为交换机vlan概念及创建

华为交换机vlan概念及创建

发布:大通cms 来源:比特大雄 日期:2019年11月11日 阅读:0

  一、 vlan概念:

  vlan:将一个局域网在逻辑上划分多个播送域

  vlan标签4个字节:TPID,固定值,0x8100

  TCL:帧的操纵信息

  1、 priority:帧的优先级(0-7)值越年夜优先级越高

  2、 CFI:MAC地址能否是经典格局,0暗示 经典,1暗示 非经典,以太网为0

  3、 Vlan ID

  以太网帧的格局:没有加上VLAN标识表记标帜 的尺度 以太网帧(untagged frame),有VLAN标识表记标帜 的以太网帧

  链路类型:

  1、access:接入链路

  PVID:代端口表缺省VLAN

  Access端口收到数据后会添加VLAN tag,VLAN ID和端口的PVID不异

  2、Trunk :当trunk端口收到帧,假如该帧不包括tag,将打上端口PVID,假如帧包括tag,则不变;当trunk端口发送帧时,该帧的VLAN ID 在trunk的同意发送列表中,若与端口的PVID不异,则剥离tag发送,若与端口的PVID分歧 ,则直接发送

  3、hybrid:既可以连主机,又可以连互换机,可以以Taaged或Untagged体例插手vlan

  VLAN划分方式:端口,MAC地址,IP子网,和谈,战略

  Voice VLAN使用:可以区分语音流量和营业流量,使语音流量优于营业流量,从而为语音流量供给包管

  二、 Vlan划分实例(拓扑图)

  1、 s1建立vlan

  [S1]vlan batch 2 to 3 #建立一组持续的vlan

  [S1]vlan 2

  [S1-vlan2]description RED #对vlan2停止描绘

  [S2]vlan 2 #建立单个vlan

  2、 设置装备摆设access端口

  [S1-Ethernet0/0/1]port link-type access

  [S1-Ethernet0/0/1]port default vlan 1

  [S1-Ethernet0/0/2]port link-type access

  [S1-Ethernet0/0/2]port default vlan 2

  3、 设置装备摆设trunk端口

  [S1-Ethernet0/0/1]port link-type trunk

  [S1-Ethernet0/0/1]port trunk allow-pass vlan all

  [S3]port-group group-number g0/0/1 to g0/0/2

  [S3-port-group]port link-type trunk

  [S2]port GigabitEthernet 0/0/1

  [S2-GigabitEthernet0/0/1]port link-type trunk

  [S2-GigabitEthernet0/0/1]port trunk allow-pass vlan all

  [S2]vlan 2

  [S1]interface g0/0/2

  [S1-GigabitEther0/0/2]port link-type trunk

  [S1-GigabitEther0/0/2]port turnk allow-pass vlan all

  [S4-GigabitEther0/0/1]port link-type trunk

  [S4-GigabitEther0/0/1]port trunk allow-pass vlan all

  本征vlan

  [S1-GigabitEthernet0/0/2]port trunk pvid vlan 2

  设置某个vlan不克不及 通

  [S1-Gigabitether0/0/2]undo port trunk allow-pass vlan 2

  [S1-Gigabitether0/0/2]port trunk allow-pass vlan 2